Forum

FT897 I was Foolish....

  • M3VSW
  • M3VSW's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
3 months 1 week ago #504 by M3VSW
FT897 I was Foolish.... was created by M3VSW
hi folks, got a FT897 with a problem, I was running new COAX in between house, break out box and end of garden, I had a radio outside testing SWR at points, and I managed, to plug in and TX into a coax that's attached to my FT897 indoors, yes I know I know, ironically I was then labeling the coax's etc...but in short I sent 5w from another radio directly into the back of my 897 which now, wont put out any power at all, it all looks normal, fans, TX lights, etc etc, but there's nothing coming out, gutted does not do it justice, but it was my fault so I need to man up ! does anyone know where I can get that sort of thing fixed, or anywhere that can help a fool restore his Radio privileges ?

thanks

Stu

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #505 by M0NKR
Replied by M0NKR on topic FT897 I was Foolish....
I would suggest talking to Tony G0MQG 2 the club if your a club member.

if not send the radio to somewhere like Martyn lynch & sons or Castle electronics. it shouldnt be too much to repair.

good luck
73
Andy
M0NKR

73

Andy
M0NKR

Please Log in or Create an account to join the conversation.

  • M3VSW
  • M3VSW's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
3 months 1 week ago #506 by M3VSW
Replied by M3VSW on topic FT897 I was Foolish....
ok, I think panic averted, i did a factory reset now all ok, some google shows its not unheard of, so will try and check it out !

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #522 by g0mqg
Replied by g0mqg on topic FT897 I was Foolish....
I can have a look if you like but you'll have to "join the queue"
Tony g0mqg

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds